Issue
When syncing transaction records to Salesforce, the following error occurs:
You must enter at least one line item for this transaction.
Possible causes
- NetSuite item does not have the corresponding Salesforce ID on the Custom tab of the item record. All items need to be synced in order for the connector to recognize them during sync. This means that there should be a Salesforce ID on the item record under the custom tab corresponding to the product in Salesforce. Alternately, there should also be a NetSuite item internal ID on the Salesforce product.
- The subsidiary of the customer record being created is not the same as the subsidiary of the item record. If the item record is not the same (or is not a child subsidiary of the customer record), the item is not be available for the customer.
- The error might be related to a Salesforce Spring 2020 update that prevents access to the sub-list records in Salesforce. Click Activate next to Enable Improved Caching of Org Schema. Use the following steps to enable improved caching of org schema:
- Log in to Salesforce.
- Click Setup > Critical Updates.
- Search for "Enable Improved Caching of Org Schema".
- Click Activate next to Enable Improved Caching of Org Schema.
For more information on sub-list sync issues, see the following:
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