Import Using XML Error

Comments

6 comments

  • Tyler Lamparter Principal Product Manager
    Awesome Follow-up
    Engaged
    Top Contributor
    Answer Pro
    Celigo University Level 4: Legendary

    Dave Guderian {{connection.http.encrypted}} is invalid. It should be something like {{connection.http.encrypted.security_key}} or however you stored it in your encrypted fields section.

    0
  • Dave Guderian
    Engaged
    Celigo University Level 4: Legendary
    Awesome Follow-up

    Thanks Tyler. I appreciate the help on this.

    Another question I have is that I have an API where the "POST" information needs to be in the URL Params as displayed below in Postman. Where would these same keys be entered in Celigo?

    0
  • Tyler Lamparter Principal Product Manager
    Awesome Follow-up
    Engaged
    Top Contributor
    Answer Pro
    Celigo University Level 4: Legendary

    Dave Guderian parameters are just put in the relative uri field just as you see in postman uri field in your screenshot.

    0
  • Dave Guderian
    Engaged
    Celigo University Level 4: Legendary
    Awesome Follow-up

    Thanks so much Tyler. So my next question is how should I send the security_key. In postman I am sending it via the Query Params, but it doesnt actually show up in the actual relative URI in Postman (as you can see from the initial screenshot).

    How do I replicate that in Celigo as Celigo is automatically adding it to the end of the URI?

     

    0
  • Kelly Izer Senior Solutions Consultant
    Awesome Follow-up
    Engaged
    Answer Pro
    Top Contributor
    Celigo University Level 4: Legendary

    Dave,

        You can put that info in the HTTP encrypted field and then call it with handlebar statement as Tyler stated before in the relative URI

    {{connection.http.encrypted.security_key}}

    0
  • Tyler Lamparter Principal Product Manager
    Awesome Follow-up
    Engaged
    Top Contributor
    Answer Pro
    Celigo University Level 4: Legendary

    Dave Guderian you should probably just use settings on the connection level so you don't have to specify this connection key on every export and import.

    0

Please sign in to leave a comment.