Skip to main content

JSON > NetSuite Extra row on Item Fulfillment Packages Subtab

Comments

2 comments

  • Official comment
    Mujtaba Ahmad 2

    Hi David,

    Unfortunately, this is a weird NetSuite behaviour only applicable for Item Fulfilment (best guess is because NS support different package sublist depending upon Shipping method). To solve this problem, Item Fulfilment needs to be created in Dynamic Mode (I would suggest to read NetSuite Help about this). This is a NS feature that stimulate creation of a record via API when its done via UI and adds fields one by one just like user is doing it. So, its important to have the right ordering of the field mapping for the records to be created. 

    To enable dynamic mode for IO NS Imports, add a new mapping on Import side , "Use Dynamic Mode", and hardcode this to "true".  This should remove the extra packing line showing up. 

  • David Gollom Channel Partner
    Celigo University Level 4: Legendary
    Answer Pro
    Great Answer
    Engaged

    Hi Mujtaba,

    Thanks for the advice. I'm familiar with dynamic mode.  I'll give that a try!  

     

    0

Please sign in to leave a comment.