Skip to main content

Skip Aggregation for EDI Missing

Comments

13 comments

  • Jeffery Hill Senior Solutions Consultant
    Celigo University Level 4: Legendary
    Engaged

    Katarina Brunnestom not sure if you can help here. Seems like a big gap for edi transactions.

     

    Here is an example where there are multiple records in the page, you all export it like this which isn't valid edi.

    0
  • viliandy leonardo Product Management Director
    Answer Pro
    Top Contributor

    Jeffery Hill 

    I'll follow up on the missing "skip aggregation" option for these file types EDIFACT, EDIX12, of Fixed Width and add it if it is not by design.

    On the 2nd comment about the edi gap transaction, would you log a support ticket so the team can investigate further?

    Thanks

    0
  • Jeffery Hill Senior Solutions Consultant
    Celigo University Level 4: Legendary
    Engaged

    I have one ticket open for UI preview working for multiple ST transaction, but not actually exporting on ticket #105904. I followed this documentation and it works in preview, but not in actual flow run.

    https://docs.celigo.com/hc/en-us/articles/4405047330331-Handle-multiple-transaction-sets-ST-SE-segments-in-an-EDI-file

    0
  • Pridhvi Product Manager
    Answer Pro
    Great Answer

    Tyler Lamparter

    1) The "Skip Aggregation" option is not available for the user in the UI for the reason that structured file imports (e.g. EDI, EDIFACT, Fixed Width) consisting of filedefinitions does not have aggregation supported on IO Imports, since we generate one file for each page.

    However, we are setting this option to true by default for these file types in the backend, this enhancement will be available to our clients by 15th-Feb-2022. If you want to set the "Skip Aggregation" there is a workaround where you can set this field in the EDI Imports in the backend with IO API. Here is the link to configure Import fields in the backend using IO API. Please let me know if you need any help with this.

    2) Regarding your comment "Noticing multiple ISA and GS segments in a single header file". I would like to know if there are multiple records in a single EDI file or only one record per EDI file because aggregation is done at the page level and not at the record level. If multiple records are being exported on a single page then we need to investigate this issue further from our side. 

    0
  • Jeffery Hill Senior Solutions Consultant
    Celigo University Level 4: Legendary
    Engaged

    Pridhvi #1 makes sense, but if it's defaulted to true, then I shouldn't be having this issue.

    I set my flow to have 1 record per page, but am still having this happen:

    0
  • Pridhvi Product Manager
    Answer Pro
    Great Answer

    Tyler Lamparter

    Thank you for your confirmation, After a meeting with the engineering team, the team confirmed that this is a known issue  and the fix for this will be released to clients by 15th-Feb-2022. Until the issue is fixed I would recommend you to use the workaround that I suggested in my previous comment to complete the step in the process. I will keep you posted once the issue is released. Please let us know if you need any help while working on the workaround.

    0
  • Jeffery Hill Senior Solutions Consultant
    Celigo University Level 4: Legendary
    Engaged

    Pridhvi I may need some help. I don't see a field for that in the get request.

    0
  • Pridhvi Product Manager
    Answer Pro
    Great Answer

    Tyler Lamparter

    I believe you should add the following line of code ("skipAggregation":true,) at the pointed location. Could you please try this and let me know if that helps.Thank you

    0
  • Jeffery Hill Senior Solutions Consultant
    Celigo University Level 4: Legendary
    Engaged

    Pridhvi I need skip aggregation to be true though so that only 1 file is made per page. You said it's set to true by default so I'm not sure how this helps me?

    0
  • Pridhvi Product Manager
    Answer Pro
    Great Answer

    Tyler Lamparter

    My sincere apologies for the confusion I created here, it should be set to true, I made a mistake. I have updated my previous comment.

    0
  • Jeffery Hill Senior Solutions Consultant
    Celigo University Level 4: Legendary
    Engaged

    Pridhvi that worked, but now I still have another issue which I have a ticket open for. In my mapping to edi, everything previews fine, but none of the mappings actually export. The support team didn't see anything wrong, but maybe we could meet real quick to review? I need to get this integration up and going. 

    0
  • Pridhvi Product Manager
    Answer Pro
    Great Answer

    Tyler Lamparter

    I'm glad to see the workaround helped in fixing the issue. Our team had investigated the issue (#105904) and found out that the issue is with the file definition and requires a modification, we are currently working on building the file definition rules. I will keep you updated with the progress on this, thank you.

    0
  • Bas van Ditzhuijzen Strategic Partner NetSuite Integration Whiz Salesforce Integration Whiz
    Answer Pro
    Engaged
    Celigo University Level 4: Legendary

    There is an easier workaround for this without having to go through the API, just temporarily set the filetype to CSV, check the skip aggregation box, set the filetype back to EDI and Save the import.

    Works and is non-destructive to any of the EDI-specific settings.

    0

Please sign in to leave a comment.