FTP to FTP transfer

Answered

Comments

4 comments

  • Pridhvi Product Manager
    Answer Pro
    Great Answer

    Hi Sinclair Dental IT Admin

    This is required if you have the Advanced "Skip Aggregation" option in the import step set to true (checked). When Skipping aggregation, this means that multiple files will be uploaded to the FTP endpoint. The Timestamp option is then required because the timestamp (so long as it includes seconds or milliseconds) in the filename will be different for each file that gets created by the import. Otherwise, the files that are being created on the FTP server will be overwritten one after another until the last file is written, causing a loss of data.

    To remove this requirement, uncheck the "Skip Aggregation" option in the FTP import step.

    A workaround is suggested in this community post, I hope this is helpful for you. If you have any questions feel free to reach out to us, thank you.

    Regards,

    Pridhvi

    0
  • Sinclair Dental IT Admin
    Engaged

    I'm sorry but I don't see a Skip Aggregation option in either the source or destination configuration, I have included sources and destination screenshots below.


    I'm trying to configure a simple FTP to FTP transfer of multiple files 

    eg

    Source                Destination
    i88011.pdf           i88011.pdf
    i88012.pdf           i88012.pdf
    i88013.pdf           i88013.pdf

    Source Advanced Settings

     

    Destination advanced settings:

    0
  • viliandy leonardo Product Management Director
    Answer Pro
    Top Contributor

    Sinclair Dental IT Admin

    The skip aggregation field is available when you choose the option of generating files from record. 

    When you simply move files (download a file and then export a file), you do not have to provide timestamp or gui for the destination filename. This is what I put in the destination file field name:

    On the export step, I have added a presavepage script to get the filename (see this post for the script example)

    Thank you

    0
  • Ricko Borja Technical Support Representative
    Great Answer
    Celigo University Level 4: Legendary

    Hi Dale,

    To clarify, please ensure the following settings on the FTP Import Step:

    1. Choose "CSV (or any delimited text file)" on the File type option (see 1st screenshot)
    2. Uncheck the "Skip aggregation" checkbox from Advanced and the timestamp for the File name will no longer be required (see 2nd screenshot)

    Thank you!

     

     

     

    0

Please sign in to leave a comment.