Skip to main content

NetSuite Item Load Does Not Return All of the Items

Comments

4 comments

  • Diksha Khatri Software Engineering Manager
    Great Answer

    Hi PaulS

    I see a small bug with your script, in the loop you're moving the array index from 0 to data.length, and in the loop you're splicing it.

    Splice operation at index i (say 4 for eg) will change the length of the array, and bring a new element at i, i+1 moved to i, (5th element moves to 4), but your i++ will still move the i to i+1. So you will end up skipping one element each time you splice something.

    You should i--, after splice at i.

    That being said, I can not understand why the flow does not process all the exported records and not show any errors too. Please fix the script and re-run it on the NetSuite saved-search data to see what is the new filtered count.

    I suggest you raise a support ticket as we'll need a closer look, so as soon as you've fixed the script and know the new filtered count, please run the flow and reach out to Celigo support if the issue still persists.

    Thanks

    0
  • PaulS
    Celigo University Level 1: Skilled
    Awesome Follow-up
    Engaged

    Thanks for the catch - I'll make the change and try again.  I had that decrement in there before but took it out as it didn't seem to act correctly for what I was doing.

    0
  • PaulS
    Celigo University Level 1: Skilled
    Awesome Follow-up
    Engaged

    I made the correction and reran the flow.  Still only 50k out of 150k were moved over.  I adjusted the page size and batch size to see if that would make a difference and it did not.  There are no errors in the flow.  The time for it to run varies between a little over 1 hour to almost 2 hours depending on the page & batch size.  I am running this against the NetSuite sandbox, but I see no errors there either.  Could there be some ceiling I'm hitting on NetSuite that stops the load?  And I created another flow that used FTP to send the saved search with all the items in it to a FTP server... and it timed out and sent no file...

    0
  • Diksha Khatri Software Engineering Manager
    Great Answer

    Hi PaulS,

    Please raise a support ticket, as we'll need to take a closer look. Since this is not completing the export and not generates an error too, we'll have to look at the debug logs, and the jobs in question.

    Please use support medium.

    0

Please sign in to leave a comment.