Skip to main content

HTTP OAUTH 2.0 refresh token not working

Comments

5 comments

  • Official comment
    Niranjan Thotapalli Senior Software Engineer

    Hi Divya,

    Can you please try to configure the connection as below:

     

    The only thing we missed is to set the 'access_type' query param for the Authorization URL. Please modify that to the one shown in the above screenshot and let us know if you still have any issues.

     

    Thanks.

  • Scott Henderson CTO
    Answer Pro
    Top Contributor

    Can you share screenshots of your full connection setup?  For example, what auth type are you using?  What grant type?  Are you setting any override fields? 

    0
  • Divya Navakumar
    Celigo University Level 3: Master
    Engaged

    Hello Scott, 

    Thank you for your reply. I already created a support ticket for the issue. I have shared the details with the Technical support representatives. I have included the screenshots for your reference below.

    Thanks,

    Divya

    0
  • Scott Henderson CTO
    Answer Pro
    Top Contributor

    Hey Divya, i deleted my last response because i was able to sync up with various folks internally, and I also scanned what all our other users are doing when they connect to various zoho apis.  Can you try setting the following circled fields, and see if this works?  Again, this is what I see other users doing.  If this does not work, then please continue working with support, and maybe there is a strange behavior specific to zoho people apis that we need to flush out still.

    Important notes:

    1. I would create a brand new connection just to make sure you start fresh.
    2. For the authorization url field you might need the "?prompt=consent", but i would try with and without.
    3. You should of course set the scope field based on what you need (i.e. i did not include a scope in my pics, but you do need this).
    4. Revoke token url should be removed.
    5. I see in the docs where they say to use the scheme -> "Zoho-oauthtoken", but I would still try to set the scheme to Bearer and see if that also works.

    0
  • Divya Navakumar
    Celigo University Level 3: Master
    Engaged

    Hi Scott,

    Thank you for the update. I tried creating a new connection with the settings you suggested.  Unfortunately I am facing the same issue. It works for the first time as long as the access token is valid ( i.e. 3600 seconds), but once the access token expires, the flow throws an oAuth token invalid error:  {"response":{"message":"Error occurred","uri":"/api/forms/P_EmployeeView/records","errors":{"code":7213,"message":"The provided OAuth token is invalid."},"status":1}}

     

    Thanks,

    Divya

    0

Please sign in to leave a comment.