BUG -> Error "Virtual exports for export type: webhook are not supported."

Comments

5 comments

  • Steve Klett Strategic Partner
    Celigo University Level 4: Legendary
    Answer Pro
    Great Answer
    Top Contributor
    Awesome Follow-up
    Engaged

    This is looking like a larger bug in IIO. As a test I just created a brand new Integration, brand new Flow and added a brand new Webhook listener. I then added a NetSuite lookup and I get the same error:

     

    Here's a video showing creating everything from scratch and still getting the error: https://www.screencast.com/t/fe2URigFQ

    I've also been able to create this in multiple accounts and from multiple users and workstations.

    0
  • Steve Klett Strategic Partner
    Celigo University Level 4: Legendary
    Answer Pro
    Great Answer
    Top Contributor
    Awesome Follow-up
    Engaged

    Created ticket #125505

    0
  • Scott Henderson CTO
    Celigo University Level 1: Skilled
    Answer Pro
    Top Contributor

    This is a generic UI specific problem where the listener bubble does not have sample data populated, and the UI is trying to invoke the source listener bubble as a virtual export to retrieve sample data on the fly, but of course you cannot invoke a listener bubble on the fly like you can a regular export, and hence the error.

    The work around is to manually add sample data to the webhook listener, and we will log a product bug that we should not even be trying to invoke a listener bubble on the fly, and then the error will go away once we fix this.

    0
  • Steve Klett Strategic Partner
    Celigo University Level 4: Legendary
    Answer Pro
    Great Answer
    Top Contributor
    Awesome Follow-up
    Engaged

    Thanks for the info Scott Henderson, I just added sample data and indeed the error stopped. It may be interesting to you that this flow was a clone (part of our new lifecycle management process using the new IIO features) and the sample data wasn't cloned for the WebHook Listeners.

    0
  • JCS Celigo Integrator 2
    Engaged

    Hi Steve Klett,

    Are you using the pre-built ShipBob connection in integrator.io with Webhooks to fetch the shipment data? Or you have created a custom HTTP connection with ShipBob?

    Could you please answer my queries? I am also trying to integrate with ShipBob but facing some issues, your reply would be a great help.

    Thanks in advance.

     

     

    0

Please sign in to leave a comment.