Issue/Error: The customer is trying to pass a product with more than one category selected. When doing so, they are getting the following error:
"We found a duplicate website, tier price, customer group, and quantity."
When running the saved search, it appears four times: Two times for each price level and each category. The category does not group the product as expected and sends a single call.
Cause:
An update has been made to the product. The change is causing issues when the customer is using categories containing a comma. The original item/matrix export saved searches contain the category field with the custom label: "Category Ids". The Integration App will get the category names separated by ',' on the saved search, but when exported, in the code, it will load the Celigo Magento 2 Category record and will prepare the ids as [1,2] by comparing them with the names. If the category contains a comma, this implementation will not work.
Resolution:
- Create a new column in the saved search for the category fields with the custom label: "Category Id".
- Delete the original one with "Category Ids".
- The Integration App will get the category ID directly from the saved search. Even though we are getting a different row for each category, the Integration App will combine those rows internally.
For example, if the customer has selected A, B categories which are having 1, 2 as ids, there will be a separate row for each one but eventually, we will combine it to [1,2].
Comments
Please sign in to leave a comment.